atlassian settings.xml does it work?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

atlassian settings.xml does it work?

forums-5
Hi, i follow the instructions "http://confluence.atlassian.com/display/DEVNET/Writing+your+first+plugin" but when i launch atlas-create-plugin-jira.bat i got these errors...:

Executing: "C:\atlassian-plugin-sdk-3.2.3\apache-maven\bin\mvn.bat
" com.atlassian.maven.plugins:maven-jira-plugin:3.2.3:create
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven Default Project
[INFO]    task-segment: [com.atlassian.maven.plugins:maven-jira-plugin:3.2.3:cre
ate] (aggregator-style)
[INFO] ------------------------------------------------------------------------
Downloading: https://m2proxy.atlassian.com/repository/public/org/apache/maven/ma
ven-artifact/2.1.0/maven-artifact-2.1.0.pom
[WARNING] Unable to get resource 'org.apache.maven:maven-artifact:pom:2.1.0' fro
m repository atlassian-public (https://m2proxy.atlassian.com/repository/public):
 Error transferring file: Connection timed out: connect
Downloading: https://m2proxy.atlassian.com/repository/public/org/apache/maven/ma
ven-artifact/2.1.0/maven-artifact-2.1.0.pom

....

my settings.xml is built like this :
<settings xmlns="http://maven.apache.org/settings/1.0.0"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
...
 <localRepository>C:\atlassian-plugin-sdk-3.2.3\repository</localRepository>
...
        <proxies><proxy>
      <active>true</active>
      <protocol>http</protocol>
      <username>myusername</username>
      <password>mypasswd</password>
      <host>proxy.XXX.</host>
      <port>8080</port>
    </proxy></proxies>
...
</settings>

I can't reach https://m2proxy.atlassian.com/repository/public/org/apache/maven/, and i wonder why? :(
thanks for help
--
Post by velderama - online at:
http://forums.atlassian.com/thread.jspa?forumID=46&threadID=50990
_______________________________________________
Jira-user mailing list
[hidden email]
To unsubscribe or change your options visit this page:
http://lists.atlassian.com/mailman/listinfo/jira-user
Reply | Threaded
Open this post in threaded view
|

Re: atlassian settings.xml does it work?

houzecl
I've got the same problem.
Did you solve it ? How ?


forums-5 wrote
Hi, i follow the instructions "http://confluence.atlassian.com/display/DEVNET/Writing+your+first+plugin" but when i launch atlas-create-plugin-jira.bat i got these errors...:

Executing: "C:\atlassian-plugin-sdk-3.2.3\apache-maven\bin\mvn.bat
" com.atlassian.maven.plugins:maven-jira-plugin:3.2.3:create
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven Default Project
[INFO]    task-segment: [com.atlassian.maven.plugins:maven-jira-plugin:3.2.3:cre
ate] (aggregator-style)
[INFO] ------------------------------------------------------------------------
Downloading: https://m2proxy.atlassian.com/repository/public/org/apache/maven/ma
ven-artifact/2.1.0/maven-artifact-2.1.0.pom
[WARNING] Unable to get resource 'org.apache.maven:maven-artifact:pom:2.1.0' fro
m repository atlassian-public (https://m2proxy.atlassian.com/repository/public):
 Error transferring file: Connection timed out: connect
Downloading: https://m2proxy.atlassian.com/repository/public/org/apache/maven/ma
ven-artifact/2.1.0/maven-artifact-2.1.0.pom

....

my settings.xml is built like this :
<settings xmlns="http://maven.apache.org/settings/1.0.0" 
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
          xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
...
 <localRepository>C:\atlassian-plugin-sdk-3.2.3\repository</localRepository>
...
        <proxies><proxy>
      <active>true</active>
      <protocol>http</protocol>
      <username>myusername</username>
      <password>mypasswd</password>
      <host>proxy.XXX.</host>
      <port>8080</port>
    </proxy></proxies>
...
</settings>

I can't reach https://m2proxy.atlassian.com/repository/public/org/apache/maven/, and i wonder why? :(
thanks for help
--
Post by velderama - online at:
http://forums.atlassian.com/thread.jspa?forumID=46&threadID=50990
_______________________________________________
Jira-user mailing list
Jira-user@lists.atlassian.com
To unsubscribe or change your options visit this page:
http://lists.atlassian.com/mailman/listinfo/jira-user